GMC HUMMER EV Forum | HummerChat.com banner
1 - 6 of 6 Posts

· Registered
Volt, Polestar 2, R1T, Livewire One
Joined
·
1,232 Posts
The weather in NY is not conducive to leaving them off either! They look and feel like glass, it’s good that they aren’t I guess!
The other issue is with the storage boxes they take up the entire trunk, it’s okay when the paneled are in them but for the next 6-8 months I don’t think I will be removing the panels, so I guess I will just clutter up my garage with the giant box…lol. Oh the problems us Hummer EV owners have!
I think the support this forum has is great!
Unlike the corvette forum….🤯
I'm really curious how other people are going to feel about having 4 wheel steering once the roads start getting slick again. It felt dangerous to me, made it way too easy to have the rear of the truck kick out. It probably doesn't help with the weight of the truck.
 

· Registered
Volt, Polestar 2, R1T, Livewire One
Joined
·
1,232 Posts
Though 4 wheel steering used right can help you regain control faster if you start to lose traction.
My brain was too confused by the feeling of the ass end having it's own mind to be able to discern that point. Probably just something that would come with more practice though.

I can't wait to get the winter tires on my Rivian and some snow on the ground so I can get a feel for how it's going to handle.
 

· Registered
Volt, Polestar 2, R1T, Livewire One
Joined
·
1,232 Posts
any lessons learned you can share on knowing if its attached properly? your story sounds like something that would happen to me...
It's possible to close the lever above the latching position, but IMO if you're paying attention, it's immediately obvious. The less obvious part is just forgetting to close the latching lever.
 

· Registered
Volt, Polestar 2, R1T, Livewire One
Joined
·
1,232 Posts
It leaked? did you have an early build? I wonder if mine has the updated I-Beam? September Build.
Also I bought the sky panel boxes, super secure, a little bulky but very secure!
My 1/22 build leaked from the I-Beam for the first time after I already sold it. Guessing I probably installed it backwards after taking it out for photos. Was fine before that.
 
1 - 6 of 6 Posts
Top